Jump to content
Corsa-C.ro
floryn_c90

Problema iluminare CD30

Recommended Posts

Salut!

Am urmatoarea problema cu CD30. Nu se aprind led-urile atunci când îl pornesc sau când pornesc farurile. În rest funcționează foarte bine. Din câte am mai citit CD30 nu are pin de Illumination, comanda de aprindere leduri fiind data prin conexiunea CAN. Menționez ca am TID cu 32 pini pe masina (Meriva A facelift cu Z14XEP). 

Am OP-COM, TIS și EPC. Am dat de schema din TIS a conectorului de la player însa din câte observ primește informația de la TID și acolo mă pierd.

 

Ms mult!

Edited by floryn_c90

Share this post


Link to post
Share on other sites

Au fost ceva modificari la masina, gen iluminare interioara cu led sau ceva de genul? Cd30 e original al masinii sau retrofit de la cdr2005? A lucrat vreodata iluminarea? Sunt erori in BCM legate de circuitul de iluminare?

Share this post


Link to post
Share on other sites

1. Luminile interioare sunt schimbate pe SMD. Nu mergea iluminarea playerului nici înainte sa fac conversia.

2. CD30 nu este original. Pe masina a fost din fabrica CD30 MP3 AUX cu jack-ul lângă frana de mana, însă vechiul proprietar l-a inlocuit cândva în trecut.

3. Nu știu dacă a lucrat vreodată iluminarea deoarece eu când am achiziționat masina, iluminarea playerului nu funcționa. 

4. Nu am erori în BCM legate de circuitul de iluminare.

Cam multe variabile. E posibil sa fie defect CD30-ul? Cum as putea sa-l testez?

Share this post


Link to post
Share on other sites

Posibil cd30 sa nu vina de pe corsa c, tigra b, meriva a, ci de pe o astra h, zafira b, corsa d, unde iluminarea e alta mancare de peste.

Fata radioului, are dunga aia pe mijloc? Poti pune o poza cu eticheta radioului?

Share this post


Link to post
Share on other sites

Fata este dreaptă. Știu cum arata cele de Astra H sau Corsa D. 

Poate sa fie de Vectra C, fiindcă acelea au tot fata dreapta, fără dunga ieșită în relief.

Dacă fac un Printscreen pe modulul de EHU din OPCOM la info ar trebui sa spună mai multe, nu? Cu eticheta mai greu fiindcă momentan  nu știu unde am pus agrafele de scoatere a playerului din bord. 

O sa urc cât mai repede un prinscreen.

Ms!

Share this post


Link to post
Share on other sites

Da, merge si din opcom. Posibil sa fie vectra c. Verifica in tis cum e circuitul.

Share this post


Link to post
Share on other sites

Salut!

Am atasat print-uri cu informatii referitoare la CD30 si la TID.

Ms!

CD30.JPG

TID.JPG

Share this post


Link to post
Share on other sites

Codul cd30 il gasesc si pe vectra c si pe meriva, corsa.

Iti trebuie un opcom sau ceva sa poti vedea valori actuale, atat in tid cat si in cd30, sa vezi unde sta procentul de iluminare.

Share this post


Link to post
Share on other sites

Daca ma conectez cu OPCOM pe DIS (TID) din modulul de Vectra C, am cateva optiuni la Measuring Blocks, una fiind si Illumination dimming. Daca rotesc de comutatorul de la blocul de lumini, se modifica lumina la TID corespunzator cu ce imi afiseaza OPCOM, in procente. Daca ma conectez normal cu datele masini, si anume Meriva, nu am acces la Measuring Blocks.

La EHU nu am aceasta optiune.

Am urmatoarele index-uri:  unul este CODE INDEX si celalalt AUDIO INDEX (playerul este Blaupunkt), poate ajuta cu ceva. Nu am incercat inca sa le programez.

O sa conectez maine interfata iarasi pe masina sa caut mai amanuntit.

Ms!

audio index.JPG

code index.JPG

Share this post


Link to post
Share on other sites

Daca ar fi acelasi hardware si la vectra si la meriva, singurul lucru care le diferentiaza este code index. Programeaza pt masina ta conform tis.

Share this post


Link to post
Share on other sites

Salut!

Am conectat OPCOM-ul iar la masina si am facut urmatoarele operatiuni:

1. Am programat atat code index cât și audio index corespunzator pentru Meriva;

2. Am citit Measurement Blocks din TID si imi arata clar nivelul de iluminare a acestuia. Foto atasat ( este 81% fiindca asa il tin eu, insa se modifica daca misc de rotita).

3. Am citit DTC-urile pe TID. Foto atasat.

Pe EHU  la Measuring Blocks am doar Security Wait Time si Security Code inputs. Nimic mai complex. Nu am DTC-uri pe EHU.

 

TID 1.JPG

TID 2.JPG

TIDF 3.JPG

Share this post


Link to post
Share on other sites

Ar trebui sa te ingrijoreze U2102-00, TID nu e programat corect pentru canbus. Daca nu e pus si EHU pe Present, logic ca TID nu trimite info de iluminare.

Masina asta are nevoie de o sesiune serioasa cu tech2. Banui ca TID nu e imperecheat cu cd30, altfel aparea display safe sau radio safe.

Edited by liviu2004

Share this post


Link to post
Share on other sites

Atât în modulul EHU cât și în DIS sunt ambele pe Present (EHU și DIS).

E posibil ca atunci când a fost schimbat playerul sa fi făcut ceva dezordine vreun " meseriaș"  prin module. 

In mare parte pot sa spun ca nu sunt împerecheate însă este ciudat faptul ca are momente când nu apare Display Safe. Cel mai mult l-am urmărit aproape o ora și nu a mai apărut Safe, timp în care îmi afișa absolut normal, mai puțin iluminarea de player. Nu l-am urmărit mai mult fiindcă am ajuns la destinație.

Din câte inteleg OPCOM-ul nu prea are ce face in situația prezentata.

Având în vedere ca nu am carpass-ul și nici codul CD30-ului, operația poate fi destul de neproductiva financiar. S-ar putea sa ies mai bine cu un CD30 MP3 gata împerecheat cu displayul și sa le montez cu totul. Ar trebui sa meargă.

Ms!

Share this post


Link to post
Share on other sites

Poti sa pui un print screen de la TID mid speed can si de la EHU mid speed can? Ai un programator de memorii? cd30 delphi are 24C32, blaupunkt are 95640.

Share this post


Link to post
Share on other sites

Code index la cd30 trebuie sa fie 001. La TID trebuie sa fie 002. Ce valori ai tu?

TID prima poza si cd70 urmatoarele 3, n-am avut alt radio la indemana:

TID.png.847ed7664aaceae0475706e0ffbf5a0b.pngehu1.png.bdba2ffcef3dca69370573237a019a13.pngehu2.png.d7002b3c4d60659234f6608e6c6b709b.pngehu3.png.820ef65ec79a1bcf7115847a8b459806.png

Edited by liviu2004

Share this post


Link to post
Share on other sites

Salut!

-  Atat in EHU cat si in DIS la MID SPEED CAN sunt ambele pe Present (prinscreen-uri mai jos);

-  In EHU am code index 001 03 iar in DIS am code index 002 01. Daca ne luam dupa primele 3 caractere, ar fi ok, insa nu stiu daca influenteaza si cele doua caractere de dupa spatiu.

-  In Measuring blocks din EHU, am doar 3 intrari in OPCOM (print atasat). Nu afiseaza nimic legat de iluminare. Probabil Tech 2 acceseaza mai multe informatii.

-  Din cate imi aduc aminte, playerul este Blaupunkt. Nu am programator de eeprom (daca la asta te referi) si nici nu am folosit. Am vazut unele destul de accesibile ca pret, si daca sunt sanse sa rezolv ceva, o sa achizitionez unul.

-  Am OPCOM firmware 1.39, soft 100219 DIAG 08/ 2010. Crezi ca exista posibilitatea sa pot accesa mai multe informatii in EHU facând upgrade la un firmware superior si folosind un soft mai recent? Interfata a venit cu FW 1.45 dar era instabila si am făcut downgrade la 1.39 cu OC Flash si nu am intampinat probleme. Nu cred ca ar fi probleme nici la upgrade.

Ms mult!  

 

01. EHU info.JPG

02. DIS - info.JPG

03. EHU - Mid-Speed CAN.JPG

04. DIS - Mid-Speed CAN.JPG

code index EHU.JPG

code index TID.JPG

EHU measuring.JPG

Share this post


Link to post
Share on other sites

Code index si can par ok. Nu inteleg eroarea de can, mai e ceva pe canbus montat. Sau eroarea e pe Not Present si trebuie doar stearsa.

Nu mai baga coduri la cd30, ca altfel tura urmatoare astepti ore bune.

Poti incerca cu opcom 2012, eu nu le mai am, ca am opcom hq si software 2016.

Programator se merita daca mai faci si altceva cu el, altfel nu prea ... Apoi tre sa te gandesti cum scoti cipul de pe placa, eu folosesc statie cu aer cald.

Eu ma impac bine cu upa usb.

Edited by liviu2004

Share this post


Link to post
Share on other sites

Eroarea de CAN este pe Not Present, i-am dat Clear azi si nu a mai aparut. In printscreenul de dinainte era selectata eroarea B1274-06, la care nu imi da descrierea. Aceasta din urma este Present si nu poate fi stearsa.

Nu am nimic altceva montat pe canbus, din cate stiu eu.

Partea cu dezlipitul cipului de pe placa cred ca ma depaseste putin. Am mai lipit cateva condensatoare pe diferite placi electronice, dar aici e cu totul altceva si marja de eroare foarte mare daca nu ai echipamente specializate.

 

Am uitat sa specific. Nu stiu daca asa trebuie sa fie, insa daca scot cheia din contact, playerul continua sa functioneze fara sa fie afectat in vreun fel. Daca nu ma insel, la Corsa CDR2005 se oprea cand scoteai cheia insa puteai sa-l pornesti iar si fara cheie. La mine exista riscul sa-l uit pornit daca este dat pe Mute si nu stiu daca se opreste dupa 30min cum ar trebui.

Edited by floryn_c90
adaugare info

Share this post


Link to post
Share on other sites

Clar nu e comunicare. Comanda de oprire vine de la display. Iti arata posturile de radio pe ecran? Sa fie firele de canbus taiate? Poti sa verifici?

Share this post


Link to post
Share on other sites

Atunci cand nu apare ''Display Safe'' imi arata Track no. si timpul scurs din melodie pe linia mare din mijloc. Pe linia de sus imi afiseaza tot timpul Ora si Temperatura. Nu am incercat sa vad daca afiseaza posturile de Radio.

Poate reusesc maine sa scot CD30-ul din bord cu alte agrafe. Pinii ar trebui sa fie cei incercuiti de mine in schema atasata. Cum as putea sa testez daca vine semnal dinspre display pe cele doua fire. Am un multimetru universal care din pacate nu are buzzer.

Revin maine cu un feedback. Ms!

pinout.png

Edited by floryn_c90
adaugare info

Share this post


Link to post
Share on other sites

Pe mid speed can ai viteza de aprox 95 kbps. Nu ai cum sa vezi asa ceva pe multimetru.

Cel mai bine e sa masori continuitate din mufa in mufa. Vreo 2-4 bolduri o sa te ajute.

Ca sa scoti radio poti folosi cuie la dimensiune.

Share this post


Link to post
Share on other sites

Salut!

Posturile de radio si frecventa le afiseaza (foto).

Partea cu oprirea la scoaterea cheiei din contact am rezolvat-o, din greseala. Am apasat butonul Settings de la CD30, am activat Ignition Logic si acum se opreste la scoaterea cheiei. Cu ocazia asta am activat si SDVC (Speed Dependant Volume Control), insa nu am apucat sa-l testez.

Nu am avut timp la dispozitie sa testez conexiunea CAN intre conectorul de la TID si cel de la CD30. Sper sa o rezolv maine.

Ms mult! 

20180323_075621-1.jpg

20180323_075624-1.jpg

20180323_075642-1.jpg

20180323_161601-1.jpg

Share this post


Link to post
Share on other sites

Daca iti arata posturile, inseamna ca exista conexiune can. Nu a mai ramas decat decodarea cd30 si imperecherea cu displayul. Daca nici asta nu merge, nu pot decat sa zic ca cd30 e defect.

Share this post


Link to post
Share on other sites

Buna. Daca esti prin apropriere de Brasov te ajut eu....

Share this post


Link to post
Share on other sites

Salut!

Am reusit sa scot azi playerul in bord, am verificat continuitatea intre TID si CD30 si este ok (ai avut dreptate #liviu2004. Nu ca m-as fi indoit de asta :)).

#lupan bogdan, distanta este destul de mare intre noi si momentan nu am planificat niciun drum prin Brasov, insa o  sa te caut daca ajung in zona.

Deocamdata ramane asa situatia. Va multumesc mult!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×